Ärger mit in nach update auf ubuntu Feisty Fawn (7.04)?

Folgenden Fehler hat apache ausgespuckt:

Invalid command ‚AuthDigestFile‘, perhaps misspelled or defined by a module not included in the server configuration

En. abstract: This article describes, what to do, when you get this error abow. The problem is, that youre configuration of apache are not compatible to the new version of apache (2.2). I will tell you, how to solve this problem using italic letters for english version.

Tja… Das Problem liegt darin, dass dieses Update mit Update von apache von 2.0 auf 2.2 verbunden war. Wenn also das Modul wie libapache2--auth-plain oder libapache2--auth-pam installiert ist, ist das herumwerkeln an /etc/apache2/apache2.conf angesagt.

(You have updated youre apache from 2.0 or 1.3 to 2.2. But you not changed youre configuration of apache. Bevor you start a new version or new configuration of apache try to check if all ist OK. Use „apache2ctl -t“ or „apache2ctl -S“ or however apache2ctl was called in your distribution.)

Statt:
(Instead of:)

AuthDigestFile /var/www/.htpasswd

ist folgendes einzugeben:
(You should have something like this:)

AuthType Digest
AuthDigestProvider file
AuthUserFile /var/www/.htpasswd

Für weiter Auskünfte empfehle ich: apache 2.2 Dokumentation zu mod_auth_digest

Installiere auf keinen Fall:
(Do not install:)

libapache2-mod-auth-sys-group

sonst kriegst Du einfach nur:
(in this case you get following errors, if youre configuration doesn’t know how to use system groups for authentification)

GROUP: username not in required group(s)

in

/var/log/apache2/error.log

zu sehen und der Login wird dir verwehrt!

An dieser Stelle erlaube ich mir noch einen Link zu einer genialen Sammlung DRM-freier mp3s.
(If you found this article good, take a look on ‚the place where you can get legal DRM free mp3 music‚. Thanks!)